Tuesday, June 2, 2009

EoMPLS on 7600 : PFC-based, SVI-based, Scalable

With the "recent" addition of the ES/ES+ cards (although some SIP cards might belong in the same category), 7600 can now support 3 types of EoMPLS configurations . Depending on your needs and the available hardware, you will find at least one between them that can help you implement your network design.

PFC-based EoMPLS
This is the most well-known EoMPLS that is configured under a physical interface or subinterface using the xconnect command. Label imposition/disposition is being done by either the SUP's PFC or the ingress module's DFC, so it's supported on all the usual LAN (i.e. 67xx) cards.

You can use it for point-to-point L2 services between single attachment circuits, where you do not require any local switching or mac-address learning. Each local attachment circuit uses a single EoMPLS pseudowire to connect to a single remote attachment circuit.

Local Router


int Gi1/1
xconnect 1.1.1.2 10 encapsulation mpls

int Gi1/2.20
encapsulation dot1q 20
xconnect 2.2.2.2 20 encapsulation mpls


Remote Router

int Gi1/1
xconnect 1.1.1.1 10 encapsulation mpls

int Gi1/2.20
encapsulation dot1q 20
xconnect 2.2.2.1 20 encapsulation mpls


SVI-based EoMPLS
This EoMPLS is configured under a vlan (SVI) interface using also the xconnect command. Label imposition/disposition is being done by the egress module (where the EoMPLS VC points to), so it must be either a SIP or an ES/ES+ based one. Also there is a limitation that you must have a L3 (sub)interface as the egress interface where the EoMPLS VC will pass through.

You can use it for point-to-point L2 services between multiple attachment circuits, where you also require local switching and mac-address learning. It's like a mini VPLS implementation, where multiple local attachment circuits use a single EoMPLS pseudowire to connect to multiple remote attachment circuits.

Local Router

int Gi1/1
switchport
switchport mode access
switchport access vlan 10

int Gi1/2
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allow vlan 10

int Vlan 10
xconnect 1.1.1.2 10 encapsulation mpls


Remote Router

int Gi1/1
switchport
switchport mode access
switchport access vlan 10

int Gi1/2
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allow vlan 10

int Vlan 10
xconnect 1.1.1.1 10 encapsulation mpls


Scalable EoMPLS
This new EoMPLS is configured under an EVC service instance using again the xconnect command. Label imposition/disposition is being done by the ingress module where the service instance is configured, so a module with EVC support (i.e. ES/ES+) is required.

You can use it for point-to-point L2 services between single attachment circuits, just like the PFC-based EoMPLS.

Besides that, when dealing with EVCs you can also configure the xconnect under a vlan (SVI) interface (when the service instance is mapped to a bridge-domain) for point-to-point L2 services between multiple attachment circuits, where you can also enable or disable local L2 connectivity using split-horizon.

Both EoMPLS configurations can be used concurrently on the same physical port, with less global resources (i.e. vlans) used in comparison to the first two EoMPLS types. Keep in mind that you still need a SIP or an ES/ES+ egress module for the SVI-based EoMPLS.

Local Router

int Gi1/1
service instance 10 ethernet
encapsulation dot1q 10
xconnect 1.1.1.2 10 encapsulation mpls
service instance 20 ethernet
encapsulation dot1q 20
rewrite ingress tag pop 1 symmetric
bridge-domain 20

int Vlan 20
xconnect 2.2.2.2 20 encapsulation mpls


Remote Router

int Gi1/1
service instance 10 ethernet
encapsulation dot1q 10
xconnect 1.1.1.1 10 encapsulation mpls
service instance 20 ethernet
encapsulation dot1q 20
rewrite ingress tag pop 1 symmetric
bridge-domain 20

int Vlan 20
xconnect 2.2.2.1 20 encapsulation mpls


Notes:
1) The vlan configured in "encapsulation vlan-id" under the service instance is local significant. The vlan configured in bridge-domain is a global vlan-id and can be different from the first one.

2) Scalable EoMPLS doesn't require global VLAN resources for the EoMPLS xconnect. In PFC-based EoMPLS each (sub)interface requires one global VLAN resource.

3) An attachment circuit (AC) is usually the customer connection to a service provider network (CE-PE). An AC may be a physical or virtual port/circuit and may be any transport technology, i.e. Frame Relay DLCI, ATM PVC, Ethernet VLAN.

16 comments:

  1. SVI based EoMPLS can also be done using WS-X6816 card in 7600. We have several circuit running SVI based EoMPLS using 6816.

    Wolv

    ReplyDelete
  2. Are you using the X6816 as a core-facing card or as a subscriber-facing card?
    I believe only SIP-400/600, ES20/40, ES20+/40+ can be used as core-facing cards for SVI based EoMPLS.
    Maybe SIP-200, FlexWAN and Enhanced FlexWAN are included too, but surely not any 6xxx card.

    ReplyDelete
  3. Sorry, I got confused. You are right, X6816 is used as a subscriber facing card. For the core, we are using OSM card.

    ReplyDelete
  4. I'm a little confused. Above you've stated that "In PFC-based EoMPLS each (sub)interface requires one global VLAN resource." Are you talking about something like this as a "sub"interface?

    !
    interface g1/1.100
    encap dot1q 100
    !

    If so, on June 3rd, regarding VLAN resources vs VLAN significance, I noticed a caption that read "per port or local significant : when a vlan-id can be the same across different ports".

    A VLAN ID that is per port or locally significant shouldn't have anything to do with the global VLAN resources, so are the two statements inconsistent or am I misunderstanding something?

    ReplyDelete
  5. Yes, this is the subinterface i'm referring to.

    If you check the last paragraph of my previous post, you'll see : "Although it might seem a little bit confusing, VLAN resource is somewhat independent of VLAN significance. i.e. in a case of a L3 subinterface, you always require a global VLAN resource, regardless of the linecard used. But whether you'll have local VLAN significance or not depends on the linecard itself."

    So, there are cases where these two are dependent and other cases where they are independent.

    Let's try to configure 2 subinterfaces using the same vlan.

    First on a 6724 card:

    7600#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    7600(config)#int gi7/1.1
    7600(config-subif)#encapsulation dot1Q 10

    7600(config)#int gi7/2.1
    7600(config-subif)#encapsulation dot1Q 10
    Command rejected: VLAN 10 not available


    7600#sh vlan internal usage

    VLAN Usage
    ---- --------------------
    10 GigabitEthernet7/1.1


    Then on a ES card:

    7600#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    7600(config)#int gi9/1.1
    7600(config-subif)#encapsulation dot1Q 10

    7600(config)#int gi9/2.1
    7600config-subif)#encapsulation dot1Q 10

    7600#sh vlan internal usage

    VLAN Usage
    ---- --------------------
    1019 GigabitEthernet9/1
    1022 GigabitEthernet9/2


    As you can in the first case (67xx card) there is a global VLAN resource per port and the vlan (10) cannot be reused on another port, so it's global significant. You can also see that the internal vlan allocated (10) is the same as the actual vlan number (10).

    In the second case (ES+ card), there is also a global VLAN resource per port, but the vlan (10) can be reused on many ports, so it's local significant. You can also see that the internal vlans allocated (1019,1022) have nothing to do with the actual vlan number (10).

    ReplyDelete
  6. Hello Tassos, Thanks for the lovely post i have been confused for a while. We are using WS-X6704-10GE in core and WS-X6724-SFP for access. SVI EoMPLS didnt work and i think its due to the hardware limitation according to ur post. Now how can I move customer vlans without SVI based EoMPLS?

    ReplyDelete
  7. Ali, depending on you design, you can use PFC-based EoMPLS (in combination with MUX-UXI if needed) or 802.1q tunneling.

    ReplyDelete
  8. Hi Tassos

    I have WS-X6704-10GE facing the core, and doenst support SVI based EoMPLS. My topology is like: CE1 --> PE1 --> PE2 --> trunk --> Backbone.

    So its work till PE2, and i am getting problem put the traffic into trunk link, this is due limitation of SVI based EoMPLS, so let me know some workaround to fix thats, Thanks

    ReplyDelete
  9. You could probably use a loopback cable to push the SVI traffic into a new port (in the same chassis) and then use EoMPLS on the port on the other side of the cable.

    ReplyDelete
  10. # show vlan int usage
    VLAN Usage
    ---- --------------------
    10 GigabitEthernet7/1.1

    (config)#int gi7/1
    (config-if)#no switchport
    (config)#no int GigabitEthernet7/1.1
    (config)#int gi7/1
    (config-if)#switchport
    .........
    (config)#int gi7/1.1
    !!!!!!

    ReplyDelete
  11. Hi Tassos,

    Could you possibly post a sample configs for the below? Quite interested to test it out.

    Thanks (jomi.sam@gmail.com)

    ==============================
    Tassos (CCIE™ #19858) said...
    You could probably use a loopback cable to push the SVI traffic into a new port (in the same chassis) and then use EoMPLS on the port on the other side of the cable.
    21 March, 2010 20:51
    ==============================

    ReplyDelete
  12. int gi1/1
    desc ** incoming **
    switchport access vlan 6
    switchport mode dot1q-tunnel

    int gi1/2
    desc ** outgoing **
    switchport access vlan 6
    switchport mode access

    int gi1/3
    desc ** EoMPLS source **
    xconnect x.x.x.x

    Then you connect Gi1/2 to Gi1/3 with a loopback cable.

    ReplyDelete
  13. Hi Tassos,

    Can you please advise I have shutdown the service instance but my SVI is still appearing up/up even if VPLS is coupled

    ReplyDelete
  14. Max,

    Although i'm not 100% sure, i believe that if at least one port (L2 switchport or EFP/BD) is active, then SVI stays up.

    ReplyDelete
  15. Hi Tassos,

    What VC Mode (port or vlan) and vlan tag 10 from example will be relayed through mpls backbone or not?

    ReplyDelete
  16. Why do you need "service instance 10 ethernet" command? What exactly is its function?

    ReplyDelete

 
Creative Commons License
This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 United States License.
Creative Commons License
This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Greece License.